ЧТО ТАКОЕ НАРДЫ?

Нарды - древнейшая игра везения и мастерства. Ee история насчитывает более пяти тысяч лет. Она очень популярна на Ближнем Востоке и в республиках Средней Азии.
Игра имеет множество названий. Одни исследователи утверждают, что название игры произошло от персидского слова "нэрд" (подтверждением этому служит то, что армяне и грузины перед каждым ходом называют количество очков вслух на старом персидском языке), другие исследователи считают родительским словом растение "нард" которое произростает в Индии и является источником благовонного масла.
Сам внешний вид игры был довольно символичен в древности. Двенадцать линий соответствовали 12 месяцам в году, деление доски на 4 части – четырем временам года, 30 шашек – числу лунных и безлунных ночей в месяце, а их движение по кругу, изображало движение звезд на небе. Сумма очков на противоположных сторонах кости равная 7 – соответствовала числу планет известных в древности, от которых происходило все дурное и хорошее.
Существует большое количество разновидностей игры. В настоящее время на территории бывшего СССР наиболее распространены "длинные" и "короткие" нарды. На Западе очень распространен "бэкгаммон" - вариант игры, похожий на "короткие" нарды.


ПРАВИЛА ИГРЫ

В комплект игры входят:
  • Игровая доска (см. рисунок);
  • Две стандартные игральные кости;

  • Два комплекта фишек (двух цветов по 15 штук).

Начальное расположение фишек показано на рисунке.

Цель игрока белыми фишками: провести свои фишки в дом белых, двигаясь в направлении белой стрелки. Игрок черными фишками должен провести свои фишки в дом черных, двигаясь в направлении черной стрелки. После этого игроки должны выбросить их на двор, кидая кости.
Начинается игра с броска каждым игроком по одной кости. Если выпали кости с одинаковым количеством очков, то бросок повторяется. Право первого хода пренадлежит игроку, выбросившему "большую" кость.
Первый игрок кидает сразу две кости. Количество очков, которые выпадут на костях, показывает на сколько полей вперед нужно передвинуть свои фишки. Например, кости показывают 2, 4. Это означает, что одной, любой (на Ваш выбор) фишкой Вы можете пойти на 2, а другой на 4 поля вперед, или одной фишкой пойти сначала на 2 поля, а потом еще на 4 поля вперед.
Если на обоих костях выпадает одинаковое количество очков (куш), то количество очков удваивается, то есть игрок играет так, будто кинул 4 кости. Например, выпало 5, 5. Здесь игрок имеет возможность переставить от 1 до 4 фишек на 5 - 20 полей в разных комбинациях.
Во время игры на одно поле позволяется ставить произвольное количество своих фишек. Поле, занятое хотя бы одной фишкой соперника, считается закрытым. На такие поля вход фишками другого цвета запрещен.
При каждом броске кубиков с начальной позиции (с головы) можно снимать только одну. Исключение составляют только первые броски каждого из играющих: если выпал куш, то снять можно две фишки, но только в том случае, если не удается использовать все ходы первой фишкой. Например 6, 6
Каждый ход должен быть выполнен полностью (нельзя, например, переставить фишку только на 4 поля, если выпало 5 очков). Если в процессе перемещения в свой дом игрок не может выполнить хода, указанного одной или двумя костями, то он либо пропускает ход, либо выполняет ход, который показывает одна кость - т. е. использовать кости максимально.
В процессе игры действует одно ограничение: игрок не может занять 6 полей подряд, т. е. перекрыть путь противнику, до тех пор, пока тот не заведет в свой дом хотя-бы одну фишку.
Как только игрок проведет все свои фишки в дом, он получает право выводить их на двор, также кидая кости. Например, выпало 5, 3. Это означает, что игрок может вывести за борт одну фишку с 5-го поля и одну с 3-го.
В процессе выведения фишек из дома игрок имеет право использовать очки, которые выпали на костях, по своему усмотрению: или полностью, или частично. Например, если выпало 6, 3, игрок может вывести с доски одну фишку с 6-го поля и переставить на три поля вперед другую фишку (с 6-го, 5-го или 4-го поля).
В процессе выведения фишек с собственного дома разрешается выводить фишки со следующих полей. Например, если на зарах выпало 6, 5, а на полях 6 и 5 нет своих фишек, то игрок может вывести из дома две фишки со следующего по порядку, четвертого поля, если и там нет своих фишек, то с третьего, если и там нет - со второго и т.д.
Игрок, который первым выведет свои фишки из дома, выигрывает партию. Возможны следующие исходы партии:

  • простой выигрыш, когда противник вывел на двор (скинул) хотя-бы одну фишку. За него вам дается 1 очко;
  • марс (2 очка) - когда противник еще не полностью завел свои фишки домой, не говоря об их скидывании;
  • домашний марс (3 очка) - крайне редкий исход, при котором все фишки противника уже дома, но он так и не скинул ни одной.

В следующей партии право первого хода предоставляется выигравшему.


О ПРОГРАММЕ

Данная программа реализует разновидность нард, именуемую "длинные".
Версия - 1.0
Дата публикации - февраль 2000 г.
Автор - Валерий Киселев, выражает благодарность Марату Шарифуллину за помощь в разработке функции оценки позиции игрока, а так-же Павлу Кожанову и Евгению Козлову за бета-тестирование.

Если Вам станут известны ошибки, допускаемые программой, Вы можете сообщить о них автору по электронному адресу mybox@rikt.ru .

Основные возможности программы:

  • Удобный, интуитивный интерфейс ;
  • Звуковое сопровождение;
  • Низкая / высокая графика;
  • Масштабирование;
  • Отмена хода;
  • Ведение статистики игры против компьютера;
  • Быстрая подсказка;
  • Автосохранение размера, положения окна и прочих настроек.

Как показало бета-тестирование, человек, никогда не игравший в нарды, или наоборот: игравший, но не работавший на компьютере, после 2-3 партий полностью осваивает программу.

Приятной игры !


КАК ИГРАТЬ?

Чтобы начать новую игру - нажмите F2, или выберите соответствующий пункт меню. При запуске программы новая игра начинается автоматически. При начале игры, да и в ее процессе курсор будет принимать вид игральных костей. Это означает, что необходимо бросить кости для розыгрыша права ходить первым, или для того, чтобы сделать ход вообще. Для выбрасывания костей достаточно щелкнуть кнопкой мыши по игральной доске, или по изображению одного из кубиков на правой панели.

Затем, выберите фишку нажатием на любую фишку в данном ряду. Если ход с данной позиции допустим, то верхняя фишка в данном ряду обозначится красной стрелкой. Одновременно с этим появятся от 1 до 4 зеленых стрелок, обозначающих места, в которые можно передвинуть данную фишку. Если подвести к зеленой стрелке курсор, то всплывающая подсказка покажет: какая кость (кости) задействованы в данном ходе.

Если ход с данной позиции по тем, или иным причинам (согласно правил ) невозможен - будет выдана подсказка и стрелки не появятся.

Поддержка клавиатуры

Данная программа полностью поддерживает клавиатуру, т.е. вы можете играть не используя мышь вообще. При этом нажатие кнопки мыши заменяется нажатием пробела на клавиатуре. Движение курсора заменяется стрелками Влево, Вверх, Вправо, Вниз. Переход с нижней фишки на место над верхней фишкой - нажатием 0 (Ins) в правой части клавиатуры. Меню вызывается нажатием клавиши Alt.

Все «горячие» клавиши для удобвтва сведены в таблицу, приведенную ниже:

Действие | «Горячая» клавиша
Перемещение по игровой доске | Стрелки
Выбор (активация) | Пробел
Перемещение низ-верх ряда | 0 (Ins) справа
Вывести справку | F1
Начать новую игру | F2
Высокая/низкая графика | F3
Включить/выключить звук | F4
Показать статистику | F5
Отменить ход | Ctrl + Z
Вызов меню | Alt (Альт)


ДОПОЛНИТЕЛЬНЫЕ ВОЗМОЖНОСТИ ПРОГРАММЫ

  • Смена графики: в зависимости от установки цветового разрешения вашего компьютера Вы можете поменять графическое представление игрового поля и фишек. Для разрешения 8 бит (256 цветов) и ниже рекомендуется низкая графика. Для разрешения 16 бит (65536 цветов) и выше - высокая.
  • Масштабирование: максимальный рекомендованный размер окна программы - 1024х768 пикселей. Дальнейшее увеличение может привести к дискретизации графики.
  • Звук: озвучиваются такие соботия как выброс костей, начало и окончание передвижения фишек.
  • Быстрая подсказка: ошибочные действия игрока вызывают появление и краткосрочное мигание подсказки. Комментарии к игре выводятся там-же.
  • Отмена хода: до того, как противник не выбросил кости, Вы имеете право отменить ход (ходы). См. Как играть?
  • Игра двух человек: программа позволяет играть как с компьютером, так и с другим человеком. Выбор осуществляется через меню
  • Статистика игры с компьютером: подсчитывает и сохраняет исходы партий против компьютера. Требует доигрывания партий, для более точного отражения статистики. Возможна очистка накопленной статистики, но без возможности восстановления.
  • Вывод состояния игры: на правой панели выводится следующая информация: выпавшие кости, неиспользованные ходы, кому пренадлежит ход, процент завершенности игры для каждого игрока (не отражает преимущества положения или наоборот), порядковый номер хода и быстрая подсказка.